Android androidTestCompile に遭遇したConflict with dependency

androidTestCompile時に以下のエラーに遭遇した。

Conflict with dependency 'com.android.support:support-annotations'. Resolved versions for app (23.1.1) and test app (22.2.0) differ.

com.android.support:support-annotations:22.2.0
をどこかで間接参照している可能性があるので、各ビルドの依存関係を確認する。

./gradlew app:dependencies

androidTestCompile - Classpath for compiling the androidTest sources.
+--- com.android.support.test:runner:0.3 
    +--- com.android.support.test:exposed-instrumentation-api-publish:0.3 
    +--- junit:junit:4.12
    |    \--- org.hamcrest:hamcrest-core:1.3 
    \--- com.android.support:support-annotations:22.2.0

runnerの0.3で間接的に参照していた。

com.android.support.test:runner:0.5にバージョンを上げて解決。